Error changing ios package name


#1

I am currently on 2.6.x and was attempting to upgrade to 2.7.x. While doing so I received an error that my ios package name was not formatted properly. It was currently set (since 2013) to a single word and I assume it needs to be in the reverse-DNS format to pass validation.

Error: App config validation failed due to the following errors:

  • core.ios.package_name Field fails pattern validation

However, when attempting to change it I am getting an error that I can only have a single project under my current plan. How can I change this name without having to upgrade my plan? Thanks!


#2

We went through a bit of a dance with package name conventions at the beginning of the 2.7.x release cycle. Google’s Gradle tools recently started breaking with some Android package names and we tried to find a way to change the Android conventions while still being consistent with iOS.

This ended up creating more problems than it solved so we decided to revert back and live with the occasional breaking package name.

If you’re on Forge Platform v2.7.4 or higher your old package names should work again.

I’ve also reset your package count if you’d still like to switch names.


#3

Thank you for the quick follow up. I will try out 2.7.4 and will reply if I have any further issues. Thanks again!