iPhone XR version 12.1.2 tabbar issue


Hi, I pushed out a new version of an app and I got a report that on an iPhone XR, version 12.1.2 the tabbar is messed up.

All module are up to date and on the latest platform build as well.

Screen shot attached


Seems like this is an old bug really

Not sure why its happening now though…

Anyhow any help would be appreciated.

EDIT: I spun up an IOS 10 simulator and it display just fine so I’m wondering if its just the XR… Will report more when I have a chance to spin that up…


Thank you for reporting this!

I’ve been able to reproduce it on my side on an iPhone XR simulator running iOS 12.1. Other devices don’t seem to be affected.

It’s similar to the issue in the SO post you linked but it is definitely a new one.

It’s very much an Apple bug, you can even see it manifest in Interface Builder.

I’ve pushed a workaround to our latest staging branch: v2.7.5


There’s a good chance Apple may fix this in a future iOS release and this could interact negatively with the workaround I’ve implement.

For this reason I’ve also added a new app config flag:


Setting this to true in your src/config.json will disable the workaround if desired.


"flags": {
    "ios_disable_iphone_xr_running_ios12_1_2_tabbar_bug_workaround": true


Hi Antoine,

Let me give this a shot on my end ( I’m having some trouble getting forge to recognize the XR simulator for some reason, keeps saying it cant find it even when its open)

Thanks for the quick fix BTW too :slight_smile:


Hi Antoine,

I was able to get it tested on the simulator, however forge still cannot find it, so I have to manually drag the build over to the emulator… Not sure if its my setup or what…

Anyhow, it appears to address the issue, however oddly enough it also offsets the margins in the wrapper so some of my other fixed elements that normally had a css prop of ‘bottom:0’ needed to have it updated to bottom:45px with a specific media query for the XR

As you have noted, this hopefully will be addressed in by apple but until then, thanks for getting this update out quickly!



It looks like the issue is still happening when you go into landscape view, portrait is fine still.



I’m not seeing an issue here but this may be because my development environment is running on Xcode 10.1 and the iOS 12.1 SDK.

We’re not quite ready to push Xcode 10.1 to production on our side, but you can give it a try on your side by building against our staging branch if you set your src/config.json to use "platform_version": "v2.7.6"

You may also need to update your local Xcode to 10.1 to get the latest simulator versions.


Hi Antoine,

I’m able to reproduce on the simulator here, I have the latest xCode and and testing with 12.1 iPhoneXr sim, 2.7.6 does not appear to fix it…


Hi Antoine,

I also just tried it on the iPhone Xs and it appears to be happening there as well ( both landscape and portrait)

However the iPhoneX does not seem to have the issue… not sure what is going on with the newer iPhones…


It’s still working for me here, on both XR and XS.

Is the issue the same as your original screenshot or slightly different?

If it’s different can you please upload a screenshot?

Are you sure the devicesdk in your local_config.json is set to iOS 12.1?


"device": "simulator",
"devicesdk": "iOS 12.1",
"devicetypeid": "com.apple.CoreSimulator.SimDeviceType.iPhone-XS"

Otherwise, can you please upload a zip with:

  1. your src/config.json
  2. the image files you’re using in the tabbar
  3. an example of the code you’re using to populate the tabbar



Maybe also try a:

xcrun simctl shutdown all
xcrun simctl erase all


Hi Antoine,

I did check and I am using IOS 12.1 and the devietypeID is correct

One thing to note however is that forge keeps saying it cant find the simulator so I am having to drag the simulator-ios file over to the sim to have it installed.

Im running simulator 10.1 with xCode 10.1 (10B61)

I have tried to get it working doing the things listed in another post about this but it will not hook in no matter what I try (im on High Sierra) if that makes and diff


Hi Antoine,

So after looking at the configs again, it appears I have the SDK version set to IOS 12.1 and not iOS 12.1 ugh anyhow running it this way appears to be working… I’m going to do some more testing…




So this is very strange…

And I wish I had an actual device iPhone XR device to test on because I’m not sure if this is a simulator bug or what… .

  1. Open the app in portrait mode, nav bar looks fine
  2. Rotate the app to landscape and the nav bar looks like the original screenshot


  1. Open the app in landscape mode and the nav bar looks good
  2. Rotate the app to portrait, and it still looks good

It appears there is something off when opening the app in portrait and switching to landscape…

** Edit **
Also, as a site note, this same functionality appears to happen with both the stable and beta branches of forge.

*** Edit 2 ***
It appears the the iPhone XS Max 12.1 has the same issue as the XR 12.1 does, regular XS seems ok still. Additionally, I downloaded a beta of xCode and 12.2 and the issue is still there unfortunately…


Hi Antoine,

I did check and I am using IOS 12.2 and the devietypeID is correct

One thing to note however is that forge keeps saying it cant find the simulator and install the app.

Im running simulator 12.2 with xCode 10.2 (10E125)

Thanks in advance.


Hi Antoine,
is there any updates on xCode 10.2 support, as we are facing some issue with iOS 12.2 and it’s urgent.
please let us know when we get the new Trigger.io platform version with xCode 10.2 support.



You provide no information about your issues so I don’t know if this will help, but you can try our staging release which has been updated to Xcode 10.2:



Hi Antoine,

Thanks for your reply,

As I have mentioned issue in my earlier 1 April Post. I reported to you trigger can’t find the simulator (v12. 2).
Now I have also tried with forge v2.7.8 Staging but the trigger is returned the same error:

Could not locate simulator for: com.apple.CoreSimulator.SimDeviceType.iPhone-X iOS 12.2 - Please check your Xcode and iOS simulator setup

Obviously, I’ve verified that we have the appropriate version of the SDK installed, and the simulator runs for the device types, I just can’t get Trigger to find it.

Im running simulator 12.2 with xCode 10.2 (10E125)

Thanks In Advance.


It never seems to find it for me :smiley: What you can do though is

  1. Load the simulator you would like to use (IOS version etc)
  2. Run forge to build to simulator (doesn’t mater what target)
  3. Once it fails to find the simulator, look in your project folder > development>ios there should be a simulator ipa file, just drag and drop that into the simulator and it should install the app

You wont get the forge console readout, however safari dev tools will work…