Issues with New App and android build


#1

When creating a new app or importing for that matter when I attempt to build the app I get this error message

error: failed processing manifest. > Task :ForgeInspector:processVanillaReleaseResources FAILED FAILURE: Build failed with an exception. * What went wrong: Execution failed for task ‘:ForgeInspector:processVanillaReleaseResources’. > Failed to process resources, see aapt output above for details. * Try: Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights. * Get more help at https://help.gradle.org

I have had this happen on multiple PC, have updated all android SDKs etc. One thing I have noticed is that it looks like the .template folder appears to be missing the ‘android’ directory, I have been able to work around this at times by add it back in, however it always deletes it when doing another build.


#2

The reason you won’t see the .template dir is that it is populated by the output of a successful build but the build is failing when gradle attempts to compile the native portions of your app.

Usually when the gradle portion of the build fails the issue lies with a module compatibility issue.

Can you attach your src/config.json as well as the full log output from running:

forge build android -v

#3

Hi Antoine,

Here is the config, basically I have everything up to date, latest of each module (do I need to use the CLI to build with the -V ? I usually just use the web version)


#4

Can you please attach it as a file to your post?

The browser and/or forum software is mutilating the quotes :stuck_out_tongue:

A command-line build will be easier to get a clean log output from yup.


#5

How can I upload a file? I only see an option to upload a photo?
(maybe this format is better? I can also just email you if that would be better)


#6

Discourse must have killed the file upload configuration in the last upgrade.

I’ve fixed it and you should be able to upload it now.

Otherwise, just email me directly :slight_smile:


#7

Ok, so I have uploaded the configg and log output

errorLog.txt (16.9 KB)
file
configFile.json (3.4 KB)


#8

Okay, you’ve run into an issue with the latest Android release from Google and the Parse module.

tl;dr:

In a fit of staggering genius someone at Google decided to rename Android’s main app icon reference from @drawable/icon to @mipmap/ic_launcher.

We’re working on a fix for this but it’s going to require some deep changes to our native module build system.

In the meantime, the workaround is to specify a custom icon in the parse module configuration.


#9

wow, Thats bananas!

Let me give this a shot and report back. Thanks!


#10

Don’t forget to also set the notification_icon field to custom_push_icon! :slight_smile:

https://trigger.io/modules/parse/current/docs/index.html


#11

I just tried it, and its working now… So weird :slight_smile:

Thanks again