Strange behavior with localforage again with Android


#1

So this is odd…

I have my app and have for a long time, set it to use crosswalk. So going forward I wanted to start to target just the default android build so I targeted the android build and ran it with the same configs I had with crosswalk

httpd
port set
trusted URL set to local host etc

When I run it, it wont seem to store not matter what I do, but crosswalk it still work?


#2

Weird… you definitely shouldn’t be seeing that if you’re already using the httpd module and have a fixed port set.

Have you tried manually deleting all versions of your app from the phone and rebooting?

We’ve seen some devices/Android-versions get a little uptight when installing over a crosswalk version with a standard android version.


#3

Antoine,

THis is really strange but I think it may have something to do with Samsung devices? When I do a test to see what browser its using, Android build pops up “Chrome 4” where crosswalk is chrome 53.

If I try and build with Android it just will not work, indexed DB is not working… any way to force chrome and not old, out dated browsers?


#4

It sounds like the system webview for the device in question is maybe a little old?

What Android version and hardware are you running?

You could maybe try:

Otherwise, at least for that device, Crosswalk is probably going to be the only way you can get access to the storage API’s.