TriggerToolkit Won't Open on Mac

I can’t open the Trigger Toolkit. I see it’s unsupported, but it’s how I used to manage users. When I log in on the website with my login credentials I don’t see the KidReports app registered to my account (david@kidreports.com). How can I manage users without the Trigger Toolkit?

If you’re logged in as the project owner you should be able to add/remove users by clicking on the appropriate project on the account page:

https://trigger.io/account/

That said, if getting access to the project owner account is an issue you may still be able to get the toolkit up and running.

I’ve put some instructions up here: Legacy instructions for Toolkit

@antoinevg

Just curious, would it not be possible to create the toolkit as a node package? I understand that right now it tied to python and browser security policies are making it difficult for the legacy toolkit to work, but seeing as the CLI runs off node why could it not just be updated to be kind of like the UI to the cli?

I can understand that its not as simple as ‘Just hook that together’ however I still do utilize the toolkit as its just, well simpler to visually see what my configs are, what modules I have installed and what settings are checked or missed. Maybe its just me but I have always really liked the toolkit UI vs the cli as its easier to read and manage.

Unfortunately, the instructions provided in the link didn’t work. Leif is no longer with KidReports and we tried logging in with his email and that account isn’t the project owner either. No one knows how to log in as the project owner, but Trigger Toolkit gave me the ability to do user management so I’m going to try harder to get the toolkit to open.

I get the following errors when following the instructions for opening the toolkit:

Davids-MBP:Trigger Toolkit davidbal$ ./signed_toolkit_launcher
Launching ./TriggerToolkit
[ DEBUG] Installed version is same as App version, using code from /Users/davidbal/Library/Trigger Toolkit
[ DEBUG] Changing workspace to /Users/davidbal/Library/Trigger Toolkit
Relaunching toolkit from library directory
Davids-MBP:Trigger Toolkit davidbal$ [ DEBUG] Installed version is same as App version, using code from /Users/davidbal/Library/Trigger Toolkit
[ DEBUG] Changing workspace to /Users/davidbal/Library/Trigger Toolkit
[ DEBUG] Starting new HTTPS connection (1): toolkit-local.com:38394
[ INFO] No update zip to extract, carrying on.
Daemon PID 44128
[ DEBUG] Toolkit startup complete, closing startup.log
[ INFO] Starting up webserver at (‘127.0.0.1’, 38394)
[ INFO] 0 sessions: []
[ INFO] Attempting to open browser at https://toolkit-local.com:38394/
[ INFO] 0 sessions: []
[ INFO] 0 sessions: []
[ INFO] 0 sessions: []
[ INFO] No sessions opened in 30 seconds, shutting down…
[ DEBUG] Starting shutdown of Toolkit web server: 1613545619.7
[ DEBUG] Web server process quitting 1613545619.74
Traceback (most recent call last):
File “run_trigger_toolkit.py”, line 144, in
main()
File “run_trigger_toolkit.py”, line 133, in main
trigger.web.main(launch_browser)
File “/Users/davidbal/Library/Trigger Toolkit/trigger/web.py”, line 59, in main
webserver.run_server(launch_browser)
File “/Users/davidbal/Library/Trigger Toolkit/trigger/webserver.py”, line 204, in run_server
lib.fork_and_run(lambda: _run_server(launch_browser, port))
File “/Users/davidbal/Library/Trigger Toolkit/trigger/lib.py”, line 180, in fork_and_run
target()
File “/Users/davidbal/Library/Trigger Toolkit/trigger/webserver.py”, line 204, in
lib.fork_and_run(lambda: _run_server(launch_browser, port))
File “/Users/davidbal/Library/Trigger Toolkit/trigger/webserver.py”, line 178, in _run_server
server.start()
File “/Users/davidbal/Library/Trigger Toolkit/trigger-dependencies/cherrypy/wsgiserver/wsgiserver2.py”, line 1838, in start
self.tick()
File “/Users/davidbal/Library/Trigger Toolkit/trigger-dependencies/cherrypy/wsgiserver/wsgiserver2.py”, line 1888, in tick
s, addr = self.socket.accept()
File “”, line 4, in accept
KeyboardInterrupt
[44128] Failed to execute script run_trigger_toolkit

I got the Trigger Toolkit opening up. I had to install Firefox and made it the default browser. I previously was using Chrome with it failed.

1 Like

Electron (and even Node as we know it today) didn’t exist at the time the CLI or Toolkit were originally released but if we were to do it again today that would definitely have been the preferred option!

The biggest obstacle to a rewrite is the rather large amount of Python code that would need to be ported:

find . -name \*.py -exec wc -l '{}' ';' | awk '{print $1}' | paste -sd'+' - | bc
2221694

:stuck_out_tongue:

Trust me, I totally understand!

I’m in the process of converting our an entire backend to node so I get the undertaking :smiley:

One thought and I’m not sure if maybe this could be a workaround would be to have just the UI portion tie into the forge cli, so the cli still runs as usual but the node app is just making the calls and or saving the config.json file.

Just to test this out, I created a quick node app and used the node-cmd package and used a command like so

const syncData=cmd.run(‘cd C:\path\to\app\ & forge build web & forge run web’);

Hitting the page then runs the command and builds / runs the web version ( for some reason I have issues with the CLI for building android still, complains with this error

Failure [INSTALL_PARSE_FAILED_NOT_APK: Failed to parse /data/app/vmdl1373976307.tmp/base.apk]
[ ERROR] Try running your app again once the device is available.)

However running it via the toolkit has no such issue…

Anyhow just a though, and could be not such a huge task to undertake to restore the toolkit UI.

Now that I have the trigger toolkit open I was able to solve the immediate need of handing user management. However, I expect the Trigger Toolkit to eventually be unable to open since it’s not supported. How can I regain access to the project owner account? No one even knows the registered email account. We’ve tried the ones that come to mind. We may need to know this to ensure we keep paying.

I’ve emailed you privately to sort this out.